Instalación de Ruby Gem en un error de Raspbian: no se pudo construir la extensión nativa de Gem

Estoy tratando de instalar una gem Ruby ( Jekyll ) y sigo recibiendo el siguiente error.

ERROR: Error installing jekyll: ERROR: Failed to build gem native extension. /usr/bin/ruby1.9.1 extconf.rb /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError) from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from extconf.rb:1:in `' 

Estoy usando una Raspberry Pi. Cuando le pregunto a Ruby su versión, obtengo lo siguiente:

 user@raspberrypi ~ $ ruby -version ruby 1.9.3p194 (2012-04-20 revision 35410) [arm-linux-eabihf] -e:1:in `': undefined local variable or method `rsion' for main:Object (NameError) 

Hace unas horas, instalé la última versión de Ruby ejecutando el comando:

 sudo curl -L https://get.rvm.io | bash -s stable --ruby 

Para averiguar el origen del problema, intenté instalar una gem diferente ( lolcat ). Se instaló con éxito y funciona perfectamente.

¿Qué estoy haciendo mal?

¡Gracias de antemano!

Entonces, he investigado otras preguntas sobre StackOverflow aquí y aquí , y descubrí que era por la versión de Ruby que tenía. Incluso si instalé el último RVM, tuve que instalar la versión correcta de Ruby ejecutando el comando:

 sudo apt-get install ruby1.9.1-dev 

Resolví mi problema. 🙂