No hay tiempo de ejecución de Javascript en Windows cuando se ejecuta el servidor de Rails

Soy completamente nuevo en Ruby on Rails, y tengo problemas para configurarlo en mi PC con Windows . He seguido con éxito las instrucciones en http://rubyonrails.org/download . Sin embargo, cuando voy a ejecutar el comando del rails server esta salida:

 C:/Ruby192/lib/ruby/gems/1.9.1/gems/execjs-1.2.9/lib/execjs/runtimes.rb:47:in `a utodetect': Could not find a JavaScript runtime. See https://github.com/sstephen son/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable) from C:/Ruby192/lib/ruby/gems/1.9.1/gems/execjs-1.2.9/lib/execjs.rb:5:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/execjs-1.2.9/lib/execjs.rb:4:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_ script.rb:1:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_ script.rb:1:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee- script.rb:1:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee- script.rb:1:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-rails-3.1.1/lib/coffee-r ails.rb:1:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/coffee-rails-3.1.1/lib/coffee-r ails.rb:1:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:68:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:68:in `block (2 levels) in require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:66:in `each' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:66:in `block in require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:55:in `each' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runt ime.rb:55:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler.rb:1 22:in `require' from C:/RoR/tickets/config/application.rb:7:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.1.1/lib/rails/comman ds.rb:52:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.1.1/lib/rails/comman ds.rb:52:in `block in ' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.1.1/lib/rails/comman ds.rb:49:in `tap' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.1.1/lib/rails/comman ds.rb:49:in `' from script/rails:6:in `require' from script/rails:6:in `' 

Cuando voy al sitio web https://github.com/sstephenson/execjs todavía no estoy seguro de cómo proceder. ¿Puede alguien apuntarme en la dirección correcta (recuerda que soy un novato)? ¡Gracias!

También encontré ese problema. La solución para mí es simplemente agregar.

 C:\Windows\System32 

al CAMINO

y reinicia tu computadora.

Conseguí que funcionara al instalar node.js desde http://nodejs.org/ (enlace INSTALAR) y agregué su ruta de instalación (incluye node.exe) a la variable de entorno “Ruta” de mi usuario de Windows. También agregué la ruta de respuesta de Yang a la variable de ventanas mencionada anteriormente.

Puede que esta no sea una respuesta universalmente popular, pero para un nuevo usuario, comentaría las líneas en el archivo gem que están cargando sass y coffeescript. No es que sean del todo malos, pero creo que agregan una complicación innecesaria para que alguien se enfrente al marco. Alternativamente, si ya está familiarizado con estos componentes, solo necesita instalar un tiempo de ejecución de javascript: uso node.js