Instalar mestizo en Ruby 1.9.3

¿Cómo puedo instalar con éxito Mongrel para ruby ​​1.9.3?

Aquí está el error:

Building native extensions. This could take a while... ERROR: Error installing mongrel: ERROR: Failed to build gem native extension. /usr/bin/ruby1.9.1 extconf.rb checking for main() in -lc... yes creating Makefile make compiling http11_parser.c compiling http11.c http11.c: In function 'http_field': http11.c:70:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c:71:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c:77:22: error: 'struct RString' has no member named 'ptr' http11.c:77:50: error: 'struct RString' has no member named 'len' http11.c:77:27: warning: left-hand operand of comma expression has no effect [-Wunused-value] http11.c: In function 'request_uri': http11.c:102:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c: In function 'fragment': http11.c:113:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c: In function 'request_path': http11.c:124:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c: In function 'query_string': http11.c:135:3: error: format not a string literal and no format arguments [-Werror=format-security] http11.c: In function 'header_done': http11.c:172:13: error: 'struct RString' has no member named 'ptr' http11.c:172:13: error: 'struct RString' has no member named 'ptr' http11.c:172:13: error: 'struct RString' has no member named 'ptr' http11.c:174:89: error: 'struct RString' has no member named 'ptr' http11.c:176:52: error: 'struct RString' has no member named 'ptr' http11.c:177:26: error: 'struct RString' has no member named 'len' http11.c: In function 'HttpParser_execute': http11.c:298:23: error: 'struct RString' has no member named 'ptr' http11.c:299:23: error: 'struct RString' has no member named 'len' http11.c:307:5: error: format not a string literal and no format arguments [-Werror=format-security] cc1: some warnings being treated as errors make: *** [http11.o] Error 1 Gem files will remain installed in /var/lib/gems/1.9.1/gems/mongrel-1.1.5 for inspection. Results logged to /var/lib/gems/1.9.1/gems/mongrel-1.1.5/ext/http11/gem_make.out 

Ya probé sudo gem install mongrel --pre e incluso el que tiene --source

No sé por qué no está funcionando. ¿Es compatible con Ruby 1.9.1 y superior?

No estas solo. En el hilo, sin embargo, hay un enlace a una posible solución . No lo he probado tan YMMV, pero parece una solución plausible.

Sin embargo, dado que Mongrel ya no se actualiza, ¿por qué no cambiar a algo como Thin ?

Edit: Lo siento, veo que estás preguntando por 1.9.3. Tengo entendido que Mongrel es (se supone que) es compatible con hasta 1.9.1, pero se rompe en 1.9.2+. Otra buena razón para cambiar a algo más moderno y mantenido.

debajo del comando,

 gem install mongrel --pre 

funciona bien.

ref: revisa este enlace para más detalles

Como dijo John B, cambia a Thin.

Después de no poder hacer que Mongrel se instale con mi configuración actual con Ruby 1.9.3, comenté a Mongrel desde mi Gemfile y agregué Thin. Esto permitió que mi aplicación se instale por completo y funcione bien.

En mi gemfile

 #gem 'mongrel', '1.2.0.pre2' gem 'thin' 

entonces corre

 bundle install