Instalación de Typhoeus Windows

Se intentó instalar Typhoeus en un entorno Windows 7. Gem se instala con éxito, pero cuando intenta ejecutar un script ruby ​​simple: requiere ‘typhoeus’

Typhoeus.get (“www.google.com”, verbose: true)

Me sale el siguiente error :: D: /Ruby193/lib/ruby/gems/1.9.1/gems/ffi-1.9.3-x86-mingw32/lib/ffi/library.rb: 133: en `block in ffi_lib ‘ : No se pudo abrir l (LoadError) url ‘: No se pudo encontrar el módulo especificado. . No se pudo abrir la biblioteca ‘libcurl.dll’: No se pudo encontrar el módulo especificado. . No se pudo abrir la biblioteca ‘libcurl.so.4’: No se pudo encontrar el módulo especificado.

Intenté agregar curl.exe y libcurl.dll que encontré en uno de los paquetes en el sitio web de curl, pero eso no ayudó. No estoy seguro de qué hacer en este momento. Gracias.

Parece haberlo descubierto. Si alguien tiene el mismo problema, asegúrese de descargar el siguiente paquete de curl.haxx.se/download.html

Win32 2000 / XP zip 7.34.0 libcurl SSL Günter Knauf 3.34 MB

Extraiga el directorio bin a donde sea y asegúrese de agregarlo a su RUTA. También agregué .DLL a PATHEXT restablecer comp y funcionó.

Acabo de tener el mismo problema en Windows 7 x64 y respondí al respecto aquí . Typhoeus requiere Ruby-FFI (ver esta respuesta) y libcurl .

La respuesta aceptada está un poco desactualizada ahora, pero la misma idea funciona :

(No agregué .DLL al PATHEXT)