problemas de instalación delgada en Windows

Estoy tratando de instalar Thin on Windows (ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]) pero aparece un mensaje de error:

C:> gem instalar extensiones nativas de construcción delgada. Esto podría llevar un tiempo … ERROR: Error al instalar thin: ERROR: Error al crear la extensión nativa de gem.

C: /rails/ruby/bin/ruby.exe extconf.rb comprobando main () en c.lib … sin crear Makefile

hacer

Utilidad de mantenimiento de progtwigs de Microsoft (R) versión 1.50 Copyright (c) Microsoft Corp 1988-94. Todos los derechos reservados.

cl -nologo -I. -I. -IC:/rails/ruby/lib/ruby/1.8/i386-mswin32 

-YO. -MD -Zi -O2b2xg- -G6 -c -Tcparser.c ‘cl’ no se reconoce como un comando interno o externo, un progtwig operable o un archivo por lotes. NMAKE: error fatal U1077: ‘C: \ WINDOWS \ system32 \ cmd.exe’: código de retorno ‘0x1’ Detener.

Los archivos gem permanecerán instalados en C: /rails/ruby/lib/ruby/gems/1.8/gems/thin-1.2.5 para su inspección. Resultados registrados en C: /rails/ruby/lib/ruby/gems/1.8/gems/thin-1.2.5/ext/thin_parser/gem_make.out

Google no parece ayudarme aquí. Alguien sabe que esta pasando?

Gracias

Thin necesita comstackr una extensión en C usada por ella. Si bien parece que tienes nmake , parece que no tienes el Visual C ++ 6.0 completo requerido para comstackrlo (el cl falta es el comstackdor de C).

Le recomendaría que utilice la comstackción de Ruby basada en MinGW, llamada RubyInstaller, que es el sucesor de One-Click Installer.

Thin proporciona binarios precomstackdos para esa versión de Ruby. Además, al agregar el kit de desarrollo como se documenta en algunos tutoriales , debería poder comstackr otras gems que carezcan de binarios para Windows.

Encontrará los detalles de la descarga y más información en el sitio web RubyInstaller

Además, si tiene más preguntas, lea la sección de preguntas frecuentes de la wiki.

Espero que ayude.

Intereting Posts