Gemspec no válido (Ruby on Rails)

He instalado Ruby on Rails en Linux raspberrypi 3.10.25+. La versión de Ruby es ruby ​​1.9.3p194. Importé un proyecto basado en ruby ​​on rails desde github ( https://github.com/iobridge/thingspeak ). Usando la línea de comandos, fui al directorio del proyecto y ejecuté “bundle install” y obtuve el siguiente error. Tenga en cuenta que ni siquiera se instaló un solo paquete.

Installing rake 10.3.1 Invalid gemspec in [/tmp/bundler20140528-7444-ym92r7/ZenTest-4.9.5/specifications/ZenTest-4.9.5.gemspec]: Illformed requirement ["= 1.8"] Installing ZenTest 4.9.5 Using i18n 0.6.9 Invalid gemspec in [/var/lib/gems/1.9.1/specifications/ZenTest-4.9.5.gemspec]: Illformed requirement ["= 1.8"] Installing minitest 4.7.5 Invalid gemspec in [/var/lib/gems/1.9.1/specifications/ZenTest-4.9.5.gemspec]: Illformed requirement ["= 1.8"] 

El mismo error se mostró para todos los paquetes.

¿Cómo puedo solucionar esto? ¡Gracias!

Este es un problema conocido . Actualice sus RubyGems y elimine e instale de nuevo la gem ZenTest :

 gem update --system gem uninstall ZenTest gem install ZenTest