Vim (ruby): NoMethodError: método no definido ‘especificaciones’

Estoy usando Vim 7.3 en Windows 7. Cuando bash abrir un archivo .rb, aparece este error. Vim (ruby): NoMethodError: método indefinido `especificaciones ‘para” C: /Ruby192/lib/ruby/gems/1.9.1 “: Cadena El archivo se abre después de presionar Intro, pero sin resaltado de syntax. Tengo los siguientes complementos de vim: rails.vim surround.vim nerd_tree.vim nerdcommenter.vim snipmates.vim

No estoy seguro si el problema es con uno de los complementos de vim. Acabo de instalar todos los complementos que mencionaste en win7 y no tengo ese problema. Sin embargo tuve un error similar reproducido cuando tuve rubygems 1.8.5, y traté de ejecutar una tarea de rake. Aquí hay un enlace a un foro que habla sobre el mismo enlace de error de rubygems

Para averiguar su versión, ejecute

gem -v 

La solución para nosotros fue rebajar rubygems.

 gem update --system 1.7.2 

EDITAR:

@ Tyler-long me está diciendo que Ruby Gems solucionó el problema y que una actualización también corrige el error. Entonces puedes simplemente hacer:

 gem update --system 

tpope ha arreglado esto. Estará en la próxima versión de vim. Mientras tanto, puede actualizar su ruby-vim ftplugin.

Reemplace $ VIMRUNTIME / ftplugin / ruby.vim con la última versión de https://github.com/vim-ruby/vim-ruby/blob/master/ftplugin/ruby.vim