Instala el error Calabash-cucumber en OS X Mavericks

Estoy tratando de instalar calabash en los mavericks de OS-x para la automatización refiriéndome al enlace: ( https://github.com/calabash/calabash-ios )

He instalado la última versión de ruby, homebrew, rbenv.

Tenga en cuenta que el comando

homebrew doctor 

me está dando una advertencia solamente:

 Warning: Xcode is installed to a directory with a space in the name. This will cause some formulae to fail to build. 

No pude eliminar esta advertencia. También algún foro sugirió que esto puede ser inofensivo.

Después de luchar con el problema de la instalación durante 2 días seguidos, estoy atascado en este punto, donde me aparece el siguiente error:

 nitzs-iMac:tabbedapp nitzarg$ sudo gem install calabash-cucumber Password: Building native extensions. This could take a while... ERROR: Error installing calabash-cucumber: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb checking for main() in -lc... yes creating Makefile make "DESTDIR=" compiling gherkin_lexer_ar.c ragel/i18n/ar.c.rl:440:1: warning: control may reach end of non-void function [-Wreturn- type] } ^ ext/gherkin_lexer_ar/gherkin_lexer_ar.c:864:18: warning: unused variable 'lexer_en_main' [-Wunused-const-variable] static const int lexer_en_main = 1; ^ 2 warnings generated. linking shared-object gherkin_lexer_ar.bundle clang: error: unknown argument: '-multiply_definedsuppress' [-Wunused-command-line-argument-hard-error-in-future] clang: note: this will be a hard error (cannot be downgraded to a warning) in the future make: *** [gherkin_lexer_ar.bundle] Error 1 Gem files will remain installed in /Library/Ruby/Gems/2.0.0/gems/gherkin-2.12.2 for inspection. Results logged to /Library/Ruby/Gems/2.0.0/gems/gherkin- 2.12.2/ext/gherkin_lexer_ar/gem_make.out 

Supongo que la instalación ha fallado porque el terminal no reconoce el comando calabash. ¿Necesito saber por qué me sale el error? ¿Es un problema de los disidentes? ¿O es un problema de Xcode-5?

Cualquier ayuda o sugerencia será apreciada. Gracias.

Miré el grupo de google calabash-ios para ti y creo que tengo la solución para tu

Intenta instalarlo así

 sudo ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future gem install calabash-cucumber 

Si eso falla, puede intentar cambiar xcode de 5.1 a uno de los anteriores (Preferencias-> Ubicaciones).

Y el enlace de referencia .

    Intereting Posts