Articles of gem de

problema de permiso de instalación de gem

qichunren@zhaobak:~> gem install hpricot ERROR: While executing gem … (Gem::FilePermissionError) You don’t have write permissions into the /opt/ruby-enterprise-1.8.7/lib/ruby/gems/1.8 directory. El usuario de inicio de sesión actual es qichunren, y el usuario de qichunre tiene permiso de escritura con .gem dir.Me gustaría saber por qué gem no instala archivos en mi casa .gem dir primero. ¿Por […]

¿Cuál es la cantidad máxima de banderas que puede manejar flag_shih_tzu?

Estoy usando la gem “flag_shih_tzu” y quiero saber cuál es la cantidad máxima de marcas que puede manejar, o si depende de la int. ¿Longitud en la columna de banderas? Lo necesito para manejar 64 banderas. ¿puede?

la gem es muy lenta

En mi servidor la búsqueda es rápida pero en mi máquina local las búsquedas de gems son lentas. ¿Puedo hacer algo para acelerar mis búsquedas de gems?

Actualizar los carriles a una versión específica

¿Cómo puedo actualizar Rails a una versión específica? Tengo Rails 3.2.2 en mi máquina local, pero necesito actualizar a la versión 3.2.3. Si ejecuto gem update rails , se actualizará a la versión 3.2.6, que es la última. ¿Cómo puedo hacer esto?

Método indefinido `acts_as_messageable_messages_path`

Estoy usando actos como mensajes , una gem de Rails, en una aplicación que tengo. Sin embargo en mi messages_controller tengo def new @message = ActsAsMessageable::Message.new end y en mi opinión tengo que arroja el siguiente error método indefinido `acts_as_messageable_messages_path ‘ No estoy muy seguro de por qué esto está sucediendo con la gem.

Rieles: la gem más nueva está instalada pero la aplicación es antigua

Estoy trabajando en Bluehost. Instalé la gem 3.2.8 de Rails, y ahora obtengo esto: > gem list –local | grep rails rails (3.2.8) Pero: rails –version Rails 2.3.11 ¿Cómo puedo hacer que el comando “Rails” use la última gem? Supongo que tiene algo que ver con mi variable $ PATH pero no tengo ni idea […]

Cómo reducir el tamaño de una gem

Actualmente estoy en el proceso de crear una gem y parece ser considerablemente más grande que las gems comparativas. En primer lugar, ¿es esto realmente un problema y, si es así, hay una forma particular de reducir el tamaño de la gem? Gema: https://rubygems.org/gems/roroacms Github: https://github.com/roroacms/roroacms

Rieles: errores al instalar la gem de la hoja de cálculo usando rubygems

Quiero ser capaz de lidiar con excel spreadhseets en Rails. Así que estoy usando la biblioteca de spreadsheet . Sin embargo, cuando uso rubygems para instalar la hoja de cálculo, obtengo una excepción: Successfully installed spreadsheet-0.7.1 1 gem installed Installing ri documentation for spreadsheet-0.7.1… unable to convert “\xE2” to UTF-8 in conversion from ASCII-8BIT to […]

No puedo hacer que cocoon trabaje en Ruby on Rails 4

He estado luchando tratando de hacer que esto funcione durante las últimas horas, y no puedo por alguna razón. He seguido los pasos casi exactamente como se indica en el enlace del repository de github. Creé una nueva aplicación siguiendo todos los siguientes pasos: # rails new demo_app # cd demo_app/ +++ added gem ‘cocoon’ […]

La liberación de rastrillo se cuelga al liberar una gem.

Estoy tratando de lanzar mi primera gem a Ruby Gems. La gem está funcionando muy bien a nivel local. Lo estoy liberando usando: $rake release Lo que me da esto en la consola: example_gem 0.0.3 built to pkg/example_gem-0.0.1.gem Tagged v0.0.1 Pushed git commits and tags Entonces el proceso se cuelga. Esperé 20 minutos, luego cancelé. […]