Articles of osx mavericks

¿Cómo arreglar el error libv8 de Gemfile en Mavericks?

Cuando ejecuto bundle install obtengo An error occurred while installing libv8 (3.11.8.17), and Bundler cannot continue. Make sure that `gem install libv8 -v ‘3.11.8.17’` succeeds before bundling. Libv8 es dependencia para gems lunchy y de otros therubyracer . Me he bloqueado en mi gem Gemfile.lock libv8 en 3.11.8.17 Pero encontré que puedo degradarlo a 3.3.10.4 […]

gem autotest-fsevent falla después de actualizar a macosx mavericks

Después de actualizar a Maveriks que tiene problemas al instalar gem autotest-fsevent Aquí está el error que recibo; Mellon:public lasdolphin$ sudo gem install autotest-fsevent Building native extensions. This could take a while… ERROR: Error installing autotest-fsevent: ERROR: Failed to build gem native extension. /Users/lasdolphin/.rvm/rubies/ruby-1.9.3-p448/bin/ruby extconf.rb extconf.rb:24:in `’: Darwin 13 is not (yet) supported (RuntimeError) Gem […]

no puede cargar dicho archivo – rubygems.rb

OK, me vuelve loco! Intento correr Ruby / Rails. MacBook-Pro-2:Library me$ rvm list rvm rubies ruby-1.9.3-p194 [ x86_64 ] ruby-2.1.0 [ x86_64 ] # => – current # =* – current && default # * – default MacBook-Pro-2:Library me$ rvm use 2.1.0 Using /usr/local/rvm/gems/ruby-2.1.0 :1:in `require’: cannot load such file — rubygems.rb (LoadError) from :1:in […]

Problemas con libxml2 al instalar Ruby on Rails en OSX Mavericks

Tengo problemas para instalar Ruby on Rails en mi terminal. ¿Alguien más ha encontrado el siguiente error en el terminal: checking for main() in -llzma… yes checking for xmlParseDoc() in libxml/parser.h… no checking for xmlParseDoc() in -lxml2… no checking for xmlParseDoc() in -llibxml2… no —– libxml2 is missing. Please locate mkmf.log to investigate how it […]

La línea de comandos de Sublime Text 2 no funciona después de la instalación de Mavericks

He preparado a través de otros subprocesos en Stack Overflow y, a pesar de mis esfuerzos, el problema no parece resolverse. Desde la instalación de OS X Mavericks no puedo abrir Sublime Text 2 desde la línea de comandos. He intentado seguir estas pautas: Setup Sublime Text 2 on OSX Mavericks for Ruby on Rails Cuando […]

Ruby on Rails: no hay conversión implícita de Array en String (DEVISE)

Recientemente actualicé a OSX Mavericks 10.9 desde 10.7, y desde entonces me ha estado causando muchos problemas. Actualicé Xcode, las herramientas de la línea de comandos, reinstalé homebrew y rvm, y finalmente conseguí que los Rails funcionaran (pasé unas 5 horas haciendo que rmagick volviera a funcionar). Sin embargo, ahora cuando bash acceder a mi […]

Problemas con Rails y Postgres después de actualizar a OS X 10.9 Mavericks

Después de actualizar a OS X 10.9 Mavericks , intenté iniciar una aplicación Rails 3, pero la conexión a la base de datos de PG no estaba funcionando. Comprobando en PGAdmin III, la base de datos todavía está allí y funciona bien. Así que intenté reinstalar la gem pg: gem uninstall pg gem install pg […]

Instalación de Rails en Mavericks

No estoy seguro de lo que sucedió, pero cuando actualicé Mavericks dice que Rails no se instala. Ejecuté el siguiente comando: rails –version Y decía “Los Rails no están instalados actualmente y ejecutan los Rails de instalación de sudo gem”. Ejecuto sudo gem install rails y obtengo lo siguiente: ERROR: Error installing rails: ERROR: Failed […]

Instala el error Calabash-cucumber en OS X Mavericks

Estoy tratando de instalar calabash en los mavericks de OS-x para la automatización refiriéndome al enlace: ( https://github.com/calabash/calabash-ios ) He instalado la última versión de ruby, homebrew, rbenv. Tenga en cuenta que el comando homebrew doctor me está dando una advertencia solamente: Warning: Xcode is installed to a directory with a space in the name. […]

Problemas para degradar a Ruby en OS X Mavericks

OS X 10.9 viene con ruby ​​2.0.0p195 pero necesito instalar Ruby 1.8.7. Sigo corriendo en errores. Tengo la instalación de Xcode5-DP y creo que las herramientas de línea de comandos también están instaladas. En la terminal: sudo rvm install 1.8.7 Searching for binary rubies, this might take some time. No binary rubies available for: osx/10/x86_64/ruby-1.8.7-p371. […]