Articles of osx mountain lion

Ruby 2.0.0 RVM falla comstackción OS X 10.8.2 Mountain Lion

Al intentar instalarlo con RVM obtengo el siguiente error: > [2013-02-25 10:09:24] make CC = /usr/local/bin/gcc-4.2 LD = ld > LDSHARED = /usr/local/bin/gcc-4.2 -dynamic -bundle CFLAGS = -O3 > -fno-fast-math -ggdb3 -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Wunused-variable -Werror=pointer-arith -Werror=write-strings -Werror=declaration-after-statement -Werror=shorten-64-to-32 -Werror=implicit-function-declaration -pipe XCFLAGS = -include ruby/config.h -include ruby/missing.h -D_FORTIFY_SOURCE=2 > -fstack-protector -fno-strict-overflow -fvisibility=hidden […]

¿Cómo puedo configurar la ruta para la aplicación heroku postgresql?

Acabo de instalar la aplicación heroku PSQL (v1.0) y tengo problemas para poder conectar mis aplicaciones de Rails con la gem pg “0.1.4”. Ya agregué la ruta PATH = “/ Applications / Postgres.app / Contents / MacOS / bin: $ PATH” a mi .profile y mis archivos .bashrc, pero nada parece permitirme ejecutar psql simplemente […]

Se produjo un error al instalar ffi (1.1.2) y Bundler no puede continuar

Ejecutando OSX Mountain Lion, en un proyecto Rails 3.0. Cuando bash actualizar mis gems con un agrupador en un proyecto de Rails, obtengo el siguiente error: An error occured while installing ffi (1.1.2), and Bundler cannot continue. Make sure that `gem install ffi -v ‘1.1.2’` succeeds before bundling. ERROR: Error installing ffi: ERROR: Failed to […]

pg gem ‘0.14.0’ en Mountain Lion falla

Acabo de actualizar de OS X Lion a OS X Mountain Lion. Mi entorno de Rails en su mayor parte se mantuvo intacta. Los únicos pasos que tuve que hacer para devolver las cosas a un buen estado fueron: – Instalar XCode 4.4 – Instalar XCode 4.4 Herramientas de línea de comandos – Instalar gcc-4.2 […]

ADVERTENCIA: Nokogiri fue construido contra LibXML versión 2.7.3, pero se ha cargado dinámicamente 2.7.8

Después de realizar una instalación nueva de Mac OS X 10.8 Mountain Lion, y después de instalar Ruby 1.9.3 y Ruby on Rails 3.2.6, inicié la consola de Rails y recibí este mensaje de advertencia: ADVERTENCIA: Nokogiri fue construido contra LibXML versión 2.7.3, pero se ha cargado dinámicamente 2.7.8 ¿Cómo puedo arreglarlo?

No puedo instalar pg gem en Mountain Lion

He tenido muchos problemas con Rails después de actualizar a Mountain Lion. Tratando de solucionar estos problemas y buscando horas en Internet, hasta ahora he hecho lo siguiente para garantizar que mi sistema tenga todas las dependencias para ejecutar los Rails después de la actualización: Actualicé mi instalación de Homebrew Actualicé mi instalación RVM Instalé […]

Instalar Ruby 1.9.3 después de haber instalado Ruby 2.0.0

Instalé el gcc-4.2 y obtuve Ruby 2.0.0, pero en el proceso eliminé algunas versiones anteriores de ruby. Específicamente, Ruby 1.9.3, ahora quiero volver e instalar esa versión usando rvm install 1.9.3 pero sigo recibiendo errores. Está utilizando gcc-4.2 para instalar, pero gcc-4.2 tiene problemas para instalar 1.9.3. ¿Cómo instalo 1.9.3 ahora que estoy en este […]

Mountain Lion instalar rvm ree-1.8.7

Intenté seguir esta otra respuesta , pero tengo los siguientes problemas: $ export CPPFLAGS=-I/opt/X11/include $ CC=/usr/local/bin/gcc-4.2 rvm reinstall ree-1.8.7 /Users/username/.rvm/src/ree-1.8.7-2012.02 has already been removed. /Users/username/.rvm/rubies/ree-1.8.7-2012.02 has already been removed. No binary rubies available for: osx/10/x86_64/ree-1.8.7-2012.02. Continuing with comstacktion. Please read ‘rvm mount’ to get more information on binary rubies. You requested building with ‘/usr/local/bin/gcc-4.2’ but […]

No se puede instalar Ruby en Mountain Lion con rvm

Intenté instalar Ruby en Mountain Lion usando rvm, pero obtuve este mensaje de error: ruby-1.9.3-p362 – #extracted to /usr/local/rvm/src/ruby-1.9.3-p362 ruby-1.9.3-p362 – #configuring Error running ‘env LDFLAGS=-L/opt/sm/pkg/active/lib CFLAGS=-I/opt/sm/pkg/active/include CPATH=/opt/sm/pkg/active/include ./configure –enable-shared –disable-install-doc –prefix=/usr/local/rvm/rubies/ruby-1.9.3-p362 –with-opt-dir=/usr/local/rvm/usr’, please read /usr/local/rvm/log/ruby-1.9.3-p362/configure.log There has been an error while running configure. Halting the installation. ruby-1.9.3-p362 is not installed. Creating alias default for […]

ln: /usr/lib/libmysqlclient.18.dylib: el archivo existe

rake aborted! dlopen(/Users/ava/.rvm/gems/ruby-2.0.0-p247/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle, 9): Library not loaded: /usr/local/lib/libmysqlclient.18.dylib Referenced from: /Users/ava/.rvm/gems/ruby-2.0.0-p247/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle Reason: image not found – /Users/ava/.rvm/gems/ruby-2.0.0-p247/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle` Corrió lo siguiente para resolver: $ sudo ln -s /usr/local/mysql/lib/libmysqlclient.18.dylib \ /usr/lib/libmysqlclient.18.dylib ln: /usr/lib/libmysqlclient.18.dylib: File exists Mi configuración: OSX 10.8.4 MySQL 5.1.71 libmysqlclient.16.dylib $ locate libmysqlclient.16.dylib /usr/lib/libmysqlclient.16.dylib /usr/local/Cellar/mysql51/5.1.71/lib/mysql/libmysqlclient.16.dylib libmysqlclient.18.dylib $ locate libmysqlclient.18.dylib /usr/lib/libmysqlclient.18.dylib En .bash_profile , tengo export […]