Articles of rvm

Especificando la versión de Rails

Decidí actualizar a Ruby 2.0.0 y Rails 4.0.0. Estoy tratando de configurar estos como mis progtwigs predeterminados, usando esta línea: rvm use 2.0.0@rails-4.0.0 –default Me sale el error Failed to load /Users/michaeldunnegan/.gemrc because it doesn’t contain valid YAML hash Mi archivo .gemrc está en blanco. No se que hacer. No puedo encontrar ninguna referencia en […]

RVM Gempath no se está estableciendo

Recientemente instalé RVM. Después de cargar mi .rvmrc , intenté bundle install y obtuve el error que me informaba que el bundler no estaba instalado. Después de instalar bundler , el error de bundler no instalado persistió. Después de una rápida excavación, descubrí que los rubygems no están utilizando las gems RVM. Aquí está la […]

¿Cómo uso el paquete exec en Aptana Studio 3.0.9 para ejecutar el depurador?

Aptana parece comenzar en la concha sh . Así que estoy intentando cambiar a zsh y ejecutar comandos para iniciar una aplicación de Rails. He cambiado mi ejecutable de depuración para que ejecute un ejecutable de Unix con el siguiente contenido: #!/usr/bin/env ruby exec(“zsh | (echo $SHELL && [[ -s ‘$HOME/.rvm/scripts/rvm’ ]] && source ‘$HOME/.rvm/scripts/rvm’ […]

Obtención de una gem de ejecución While … (Gem :: RemoteFetcher :: FetchError) 503 error al intentar instalar Rails

Este es el error que recibo cuando trato de hacer un “gem install rails -v 4.1.0” usando Ruby 2.1.1 y RVM. ERROR: Al ejecutar gem … (Gem :: RemoteFetcher :: FetchError) Servicio de mala respuesta 503 no disponible ( http://api.rubygems.org/api/v1/dependencies?gems=activerecord ) ¿No está seguro de lo que está causando esto, alguien tiene alguna idea?

Ruby actualizado en producción y ahora Rails no se iniciará porque aún hace referencia al antiguo ruby

Acabo de actualizar Ruby en un servidor de prueba a través de RVM: $ rvm upgrade 1.9.3-p327 1.9.3-p362 Dije ‘sí’ a todas las preguntas sobre migración y alias, incluida la eliminación del antiguo Ruby. Ahora obtengo un error de Passenger cada vez que bash acceder a la aplicación Rails: Error message: dlopen(/Library/WebServer/rails/myapp/shared/bundle/ruby/1.9.1/gems/bcrypt-ruby-3.0.1/lib/bcrypt_ext.bundle, 9): Library not […]

Problemas con la gem mysql en osx 10.6.8

Estoy actualizando mi base de datos de sqlite a mySQL (@ mu es demasiado corto … Lo sé. Lo sé. Debería haberlo hecho al principio) y tengo un problema. Aquí está el proceso hasta ahora: Paso 1: actualiza database.yml y ejecuta rake db: schema: load as this rake aborted! Please install the mysql adapter: `gem […]

¿Paquetes requeridos que faltan? – Incluyendo libyaml

Siento que mi computadora tiene algunos problemas profundamente arraigados y está 100% en mi contra al instalar Rails / ruby ​​/ rvm y el rest en ellos. O simplemente soy incompetente 🙂 He instalado rvm y ruby ​​sin problemas. Aquí está mi configuración actual (Log from Terminal): Mac-mini:rubygems-1.8.25 Riley$ rvm -v rvm 1.18.15 (master) by […]

RVM y Pasajero: No hay ningún archivo para cargar – bundler

He visto otros errores similares, pero ninguna de las soluciones ha funcionado para mí: En Snow Leopard, estoy usando RVM con gemsets basados ​​en proyectos. Tengo las aplicaciones Rails 2 y Rails 3. Cuando uso bundler con Rails 2 o con Rails 3, obtengo: no such file to load — bundler En mis aplicaciones de […]

¿Cómo actualizo una aplicación rails 3.2 de ruby ​​1.9.3 a ruby ​​2.1.5 usando rvm?

La aplicación My Rails 3.2 / Ruby 1.9.3 está usando RVM. Quiero actualizar a usar ruby ​​2.1.5. He usado RVM para instalar Ruby 2.1.5 también. Así que la rvm list muestra tanto 1.9.3 como 2.1.5 Mi directorio de proyectos tiene un archivo .rvmrc que especifica environment_id = “ruby-1.9.3-p551@current_foogems” Así que tengo un gemset llamado current_foogems […]

Ruby on rails PIK gemset como RVM gemset?

He trabajado con RVM donde puedo obtener gemset y esas cosas, pero ¿no hay forma de obtenerlo con PIK? ¿alguna idea? Intenté buscar una solución pero no pude encontrar una. Esperemos que alguien tenga alguna pista sobre este tema? ¡Gracias!